re = /(\(.*?\))/
str = 'Non-rapid eye movement sleep (NREMS).
Cytokines such as interleukin-1 (IL-1), tumor necrosis factor, acidic fibroblast growth factor (FGF), and interferon-alpha (IFN-alpha).'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end