$re = '/(?:\?.*?&|\?)journey=([^&]*)/';
$str = 'http://www.whitelabelhosting.co.uk/flight-search.php?dept=any&journey=R&DepTime=0900 ';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);