re = /(?!.*[.]{2})((https?|http)\:\/\/)?([a-z0-9+!*(),;?&=\$_.-]+(\:[a-z0-9+!*(),;?&=\$_.-]+)?@)?([a-z0-9-.-.]?.*)\.([a-z]{2,1000})(\:[0-9]{2,5})?(\/([a-z0-9+\$_-]\.?)+)*\/?(\?[a-z+&\$_.-][a-z0-9;:@&%=+\/\$_.-]*)?(#[a-z_.-][a-z0-9+\$_.-]*)?/m
str = 'https://www.amazon.in/Sony-MDR-EX15AP-Stereo-Headphones-Black'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end