$re = '/<td><a href="readmail\.html\?id=(.*?)">/m';
$str = '<td><a href="readmail.html?id=xsX321dsa">Hi</a></td>';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);