$re = '/(?<=\||^)[a-z]+@[0-9]+(?=\||$)/i';
$str = '|ABC@123|abc@123456|ABcD@12';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);