// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"\\doc(.*?)(?:\\in|\n)").unwrap();
let string = "\\doc doc1,doc2
\\doc doc1,doc2 \\in filed1,field2
\\doc doc1,doc2 \\in filed1,field2 \\doc doc3,doc4 \\in field3,field4";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}