import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?<!\\?)\\.(js|css|png|jpe?g|gif|svg|eot|otf|ttc|ttf|woff2?)(?!\\.)";
final String string = "test.png\n"
+ "test.jpg\n"
+ "test.jpeg\n"
+ "test.ttf.ttf?v=2.0e\n"
+ "/some.directory/with.dots/\n"
+ "/some.directory/with.dots/file.ttf\n"
+ "/some.directory/with.dots/file.ttf?foo=bar\n"
+ "/some.directory/with.dots/file.ttf?foo=bar?.ttf\n"
+ "/some.directory/with.dots/file.ttf.ttf.ttf\n"
+ "/some.directory/with.dots/file.ttf";
final Pattern pattern = Pattern.compile(regex, Pattern.CASE_INSENSITIVE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}