$re = '/^(\d{3})-(\d{2})-(\d{4})$/';
$str = '345-15-4978';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);