use strict;
my $str = 'My input string & constraints are as follows :
IPv4 Range : 0.0.0.0 to 255.255.255.255 55.123.99.988 256.1.1.1
IPv4 address may / may not be present in the string
Valid Examples : this is an ip & this is an ip 200.100.2.32
String may start with IPv4 address
Valid Examples :
200.100.2.32 is an ip | Output : [\'200.100.2.32\']
Invalid Examples :
200.100.2.32is an ip | Output : []
String may end with IPv4 address
Valid Examples : the ip is 200.100.2.32
Output : [\'200.100.2.32\']
Invalid Examples : the ip is200.100.2.32
Output : []
String may contain an IPv4 address in the middle, and if it does - there will a space before and after the IPv4 address.
Valid Examples : the ip is 200.100.2.32 and it is ipv4 | Output : [\'200.100.2.32\']
Valid Examples : the ip is 200.100.2.32and it is ipv4 | Output : []
Multiple IPs may be present in a single string
Valid Examples : 200.100.2.32 100.50.1.16 | Output : [\'200.100.2.32\', \'100.50.1.16\']
Invalid Examples : 200.100.2.32.100.50.1.16 | Output : []
';
my $regex = qr/(?:^|\b(?<!\.))(?:1?\d?\d|2[0-4]\d|25[0-5])(?:\.(?:1?\d?\d|2[0-4]\d|25[0-5])){3}(?=$|[^\w.])/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}