package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`([^\W_]+[^\s-]*)*`)
var str = `insert your test string here`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}