$re = '/:20:(.*?):86:/s';
$str = ':20:160212-2359
:21:600******444
:28C:00001/00001
.
.
.
:65:D120317GBP12***,45
:65:D120318GBP1***7,45
:86:FORWARD AVAILABLE FUNDS SHOW ITEMS KNOWN BUT NOT YET POSTED
some more comments in 86_2 segment
this is line2
:20:160212-2359
:21:B***22
:25:60*****88
.
.
.
:65:D120317GBP12***,45
:65:D120318GBP1***7,45
:86:FORWARD AVAILABLE FUNDS SHOW ITEMS KNOWN BUT NOT YET POSTED
some more comments in 86_2 segment.
:20:160212-2359
:21:B****X
:25:6*************1
:28C:00001/00001
:65:C1**15EUR0,00
:65:C1**316EUR0,00
:65:C1**317EUR0,00
:65:C1**318EUR0,00
:86:FORWARD AVAILABLE FUNDS SHOW ITEMS KNOWN BUT NOT YET POSTED
{newline}';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);