const regex = /^.*liferay.*deploy-hot.*/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^.*liferay.*deploy-hot.*', 'gm')
const str = `axa-es-liferay/ned/preprod/int/deploy-hot
axa-es-liferay/ned/dev/des/deploy-hot
axa-es-liferay/portales/dev/des/deploy-hot
axa-es-liferay/portales/dev/des/deploy-develop`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}