# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"(?:(4\d{3}(?P<DelimVI>[\ \-]?)(?:\d{4}(?P=DelimVI)){2}\d(?:\d{3})?)|(5([1-5]\d{2})(?P<DelimMC>[\ \-]?)\d{4}(?P=DelimMC)\d{4}(?P=DelimMC)\d{4})|(3[47]\d\d(?P<DelimAX>[\ \-]?)\d{6}(?P=DelimAX)\d{5}))"
test_str = ("\"This is Visa number 4111111111111111, next is MasterCard number 5105105105105100, next is Amex 378282246310005\"\n\n"
"//Visa 13 or 16 digits with optional delimiters of spaces or dashes between number groups, e.g.“4012-8888-8888-1881” or “4012-8888-8888-1”.\n"
"\"//Master 16 digits with optional delimiters of spaces or dashes between number groups, e.g.“5112-8888-8888-1881” \n"
" //American Express with optional matching delimiters of spaces or dashes between number groups, e.g. “3714-496353-98431” or “3714 496353 98431”, but not mix of delimeters “3714-496353 98431” .\n\n"
"(4\\d{3}(?P<DELIM>[\\ \\-]?)(?:\\d{4}(?P=DELIM)){2}\\d(?:\\d{3})?)\n\n"
"(?:(4\\d{3}(?P<DelimVI>[\\ \\-]?)(?:\\d{4}(?P=DelimVI)){2}\\d(?:\\d{3})?)|(5([1-5]\\d{2})(?P<DelimMC>[\\ \\-]?)\\d{4}(?P=DelimMC)\\d{4}(?P=DelimMC)\\d{4})|(3[47]\\d\\d(?P<DelimAX>[\\ \\-]?)\\d{6}(?P=DelimAX)\\d{5}))")
matches = re.finditer(regex, test_str)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.