$re = '/(?<!Series\s)\b[Cc]\b((?![+.])|\.$)/m';
$str = 'C++ is cool too. C Is still a langue. C.';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);