import re
regex = re.compile(r"\s+TRN\s+[a-z\d]+\s+\d+\s+(\s+\d+\s+)\w+(\s+\d{2}\w{3}\s+)\d\s([a-z]{5})\s+([a-z]{5})\s[a-z\d]+\s+[\D]+(\d{4}|\d{0})\s+(\d{4}|\d{0})", flags=re.IGNORECASE)
test_str = ("4 TRN 2C 87 6628 AF 26NOV 4 FRLPD FRPLY HK1 1800 2007 \n"
"3 TRN 2C 87 5266 BI 16NOV 1 FRBOJ FRMLV HK PAST 3333 3333*\n"
"4 TRN 2C 87 5454 BI 19NOV 4 FRMLV FRBOJ HK PAST *\n"
"3 TRN 2C 87 5266 BI 16NOV 1 FRBOJ FRMLV HK PAST *\n"
"4 TRN 2C 87 5454 BI 19NOV 4 FRMLV FRBOJ HK PAST *\n"
"3 TRN 2C 87 6609 AF 23NOV 1 FRPLY FRLPD HK PAST *\n"
"4 TRN 2C 87 6628 AF 26NOV 4 FRLPD FRPLY HK1 1800 2007\n"
"3 TRN 2C 87 6817 AF 25NOV 3 FRLPD FRBZR HK1 1810 2047\n"
" FRLPD/LYON PART DIEU//FRBZR/BEZIERS /TGD *\n"
"4 TRN 2C 87 6860 AF 27NOV 5 FRBZR FRLPD HK1 1618 1850\n"
" FRBZR/BEZIERS//FRLPD/LYON PART DIEU /TGD *\n"
"3 TRN 2C 87 6201 BF 23NOV 1 FRPLY FRVLA HK PAST *\n"
"4 TRN 2C 87 6194 BF 24NOV 2 FRVAF FRPLY HK1 0843 1110\n"
" FRVAF/VALENCE VILLE//FRPLY/PARIS GARE LYON /TGD *\n"
"3 TRN 2C 87 3101 B 24NOV 2 FRPSL FRAEZ HK1 0653 0903\n"
" FRPSL/PARIS ST LAZARE//FRAEZ/LE HAVRE /TIB *\n"
"4 TRN 2C 87 3130 A 25NOV 3 FRAEZ FRPSL HK1 1757 2010\n"
" FRAEZ/LE HAVRE//FRPSL/PARIS ST LAZARE /TIB *\n"
"3 TRN 2C 87 6700 BF 26NOV 4 FRAEK FRPLY HK1 0542 0837\n"
" FRAEK/MULHOUSE VILLE//FRPLY/PARIS GARE LYON /TGD *\n"
"4 TRN 2C 87 9223 BF 27NOV 5 FRPLY FRAEK HK1 1823 2103\n"
" FRPLY/PARIS GARE LYON//FRAEK/MULHOUSE VILLE /TGL *\n"
"3 TRN 2C 87 5352 BF 26NOV 4 FRLPD FRDJU HK1 0629 0835\n"
" FRLPD/LYON PART DIEU//FRDJU/MASSY TGV /TGD *\n"
"4 TRN 2C 87 5233 BF 26NOV 4 FRDJU FRRNS HK1 1538 1747\n"
" FRDJU/MASSY TGV//FRRNS/RENNES /TGA *\n"
"5 TRN 2C 87 5346 BF 27NOV 5 FRRNS FRLPD HK1 1609 2030\n"
" FRRNS/RENNES//FRLPD/LYON PART DIEU /TGD *\n"
"3 TRN 2C 87 6602 BF 30NOV 1 FRLPD FRPLY HK1 0602 0813\n"
" FRLPD/LYON PART DIEU//FRPLY/PARIS GARE LYON /TGD *\n"
"4 TRN 2C 87 6629 BF 04DEC 5 FRPLY FRLPD HK1 1857 2057\n"
" FRPLY/PARIS GARE LYON//FRLPD/LYON PART DIEU /TGD")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")