const regex = /\b\d+\s+[A-Z][a-z][^_]*_[^,]+,\s+\S+/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('\\b\\d+\\s+[A-Z][a-z][^_]*_[^,]+,\\s+\\S+', 'gm')
const str = `001 ALLAN Witham Ross 13 Every_Street, Welltown Greenkeeper 002 ALLARDYCE Margaret Isabel 49 Bell_Road, Musicville Housewife 003 ALLARDYCE Mervyn George 49 Bell_Road, Musicville Company Mngr
`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}