using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?:[^""\\]|(?:\\\\|\\"")+)("")";
string input = @"{ # ""comment 1
""hello"": ""Wor#d"", ""Bye"": ""\""M#rk\"", ""yes\\\"": 5,# comment"" 2
""quote"": ""\""th#t's\"" what she said"", # comment ""3""
""list"": [1, 1, ""#"", ""\"", ""\\"", 8], ""dict"": {""q"": 7} #"" comment 4 with quotes
}
# comment 5""
";
RegexOptions options = RegexOptions.Multiline | RegexOptions.IgnoreCase;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}