$re = '/{{.*?}}/';
$str = '{{1:123}} asdfadfasdfdfdfsaf {{1212:}}';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);