import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = " (el|para|por|que|cual|como|de|sus|un?)\\s";
final String string = "el rayoluna\n"
+ "yo no sé si esto eshistoriaparece cuento ocuentoparece historia lopuedo decir esen su fondo hayverdadverdad muy tristelaacaso yo seré unolos últimos en aprovecharme dadas mis condicionesimaginación\n\n"
+ "otro con esta idea tal vez hubiera hechotomofilosofía lacrimosa yo he escrito esta leyendaa losnada vean en su fondo al menos podrá entretenerlesrato\n"
+ "era noble había nacido entreestruendolas armas yinsólito clamoruna trompaguerra no le hubiera hecho levantar la cabezainstante ni apartarojospunto del oscuro pergamino enleía la última cantigaun trovador\n\n"
+ "osquisieran encontrarle no lo debían buscar enanchuroso patiosu castillo donde los palafreneros domaban los potros los pajes enseñaban a volar a los halcones y los soldados se entretenían los díasreposo en afilarhierrosu lanza contrapiedra\n\n"
+ "dónde está manrique dónde está vuestro señor preguntaba algunas veces su madre\n\n"
+ "no sabemos respondíanservidores acaso estará enclaustro del monasteriola peña sentado al bordeuna tumba prestando oído a ver si sorprende alguna palabrala conversaciónlos muertos o enpuente mirando correr unas tras otras las olas del ríodebajosus arcos o acurrucado en la quiebrauna roca y entretenido en contar las estrellas del cielo en seguirnube con la vista o contemplar los fuegos fatuoscruzanexhalaciones sobrehazlas lagunas en cualquiera parte estará menos en donde esté todomundo\n\n"
+ "en efecto manrique amaba la soledad y la amabatal modoalgunas veces hubiera deseado no tener sombra porque su sombra no le siguiese a todas partes\n\n"
+ "amaba la soledad porque en su seno dando rienda suelta a la imaginación forjabamundo fantástico habitadoextrañas creaciones hijassus delirios yensueñospoeta tantonunca le habían satisfecho las formas enpudiera encerrarpensamientos y nunca los había encerrado al escribirlos\n\n"
+ "creíaentre las rojas ascuas del hogar habitaban espíritusfuegomil colorescorríaninsectosoro a lo largolos troncos encendidos o danzaban enluminosa rondachispas en la cúspidelas llamas y se pasaba las horas muertas sentado enescabel junto a la alta chimenea gótica inmóvil y con los ojos fijos en la lumbre\n\n"
+ "creíaenfondolas ondas del río entre los musgosla fuente y sobre los vapores del lago vivían unas mujeres misteriosas hadas sílfides u ondinasexhalaban lamentos y suspiros o cantaban y se reían enmonótono rumor del agua rumoroía en silencio intentando traducirlo\n\n"
+ "en las nubes enaire enfondolos bosques en las grietaslas peñas imaginaba percibir formas o escuchar sonidos misteriosos formasseres sobrenaturales palabras ininteligiblesno podía comprender\n\n"
+ "amar fabía nacidosoñaramor nosentirlo amaba a todas las mujeresinstante a ésta porque era rubia a aquélla porque tenía los labios rojos a la otra porque se cimbreaba al andarun junco\n\n"
+ "algunas veces llegaba su delirio hastapuntoquedarsenoche entera mirando a la lunaflotaba encielo entrevaporplata o a las estrellastemblaban a lo lejoslos cambianteslas piedras preciosas en aquellas largas nochespoético insomnio exclamaba si es verdadel priorla peña me ha dichoes posibleesos puntosluz sean mundos si es verdaden ese globonácarrueda sobre las nubes habitan gentes qué mujeres tan hermosas serán las mujeresesas regiones luminosas y yo no podré verlas y yo no podré amarlas cómo será su hermosura cómo será su amor\n\n"
+ "manrique no estaba aún lo bastante locoque le siguiesen los muchachos pero sí lo suficientehablar y gesticular a solasesdonde se empiezasobredueropasaba lamiendo las carcomidas y oscuras piedraslas murallassoria haypuenteconducela ciudad al antiguo conventolos templarios cuyas posesiones se extendían a lo largola opuesta margen del río\n\n"
+ "en la época anos referimos los caballerosla orden habían ya abandonadohistóricas fortalezas pero aún quedaban en pie los restoslos anchos torreonessus muros aún se veíanen parte se ven hoy cubiertoshiedra y campanillas blancas los macizos arcossu claustro las prolongadas galerías ojivalessus patiosarmas en lassuspirabaviento congemido agitando las altas hierbas\n\n"
+ "en los huertos y en los jardines cuyos senderos no hollaban hacía muchos años las plantaslos religiosos la vegetación abandonada a sí misma desplegaba todasgalas sin temorque la mano del hombre la mutilase creyendo embellecerla as plantas trepadoras subían encaramándoselos añosos troncoslos árboles las sombrías callesálamos cuyas copas se tocaban y se confundían entre sí se habían cubiertocésped los cardos silvestres y las ortigas brotaban en mediolos enarenados caminos y en dos trozosfábrica próximos a desplomarsejaramago flotando al vientoel penachouna cimera y las campanillas blancas y azules balanceándoseencolumpio sobrelargos y flexibles tallos pregonaban la victoriala destrucción y la ruina\n\n"
+ "eranochenocheverano templada llenaperfumes yrumores apacibles y conluna blanca y serena en mitadun cielo azul luminoso y transparente\n\n"
+ "manrique presa su imaginaciónun vértigopoesía despuésatravesarpuente desde donde contemplómomento la negra siluetala ciudadse destacaba sobrefondoalgunas nubes blanquecinas y ligeras arrolladas enhorizonte se internó en las desiertas ruinaslos templarios\n\n"
+ "a media noche tocaba a su punto a lunase había ido remontando lentamente estaba ya en lo más alto del cielo cuando al entrar enoscura alamedaconducía desdederruido claustro a la margen del duero manrique exhalógrito leve y ahogado mezcla extrañasorpresatemor yjúbilo\n\n"
+ "enfondola sombría alameda había visto agitarsecosa blancaflotómomento y desapareció en la oscuridad a orla del trajeuna mujeruna mujerhabía cruzadosendero y se ocultaba entrefollaje enmismo instante enel loco soñadorquimeras o imposibles penetraba en los jardines\n\n"
+ "una mujer desconocida en este sitio a estas horas esa esa es la mujeryo busco exclamó manrique y se lanzó en su seguimiento rápidouna saetalegó al punto enhabía visto perderse entre la espesuralas ramas a la mujer misteriosa fabía desaparecidodónde allá lejos muy lejos creyó divisarentre los cruzados troncoslos árbolesuna claridad oforma blancase movía\n\n"
+ "es ella es ellalleva alas en los pies y huyeuna sombra dijo y se precipitó en su busca separando con las manos las redeshiedrase extendíanun tapizunos en otros álamos legó rompiendoentre la maleza y las plantas parásitas hastaespecierellanoiluminaba la claridad del cielo nadie ahaquíaquí va exclamó entonces oigopisadas sobre las hojas secas ycrujidosu trajearrastrael suelo y roza en los arbustos y corría y corríaun locoaquíallá y no la veía pero siguen sonandopisadas murmuró otra vez creoha hablado no hay duda ha habladovientosuspira entre las ramas las hojasparecerezan en voz baja me han impedido oír loha dicho pero no hay duda vaahí ha hablado ha hablado en qué idioma no sé pero eslengua extranjera y tornó a correr en su seguimiento unas veces creyendo verla otras pensando oírla ya notandolas ramasentre las cuales había desaparecido se movían ya imaginando distinguir en la arena la huellasus propios pies luego firmemente persuadidoqueperfume especialaspiraba a intervalos eraaroma perteneciente a aquella mujerse burlabaél complaciéndose en huirleentre aquellas intrincadas malezas afán inútil\n\n"
+ "vagó algunas horasun lado a otro fuerasí ya parándoseescuchar ya deslizándose con las mayores precauciones sobre la hierba ya encarrera frenética y desesperada\n\n"
+ "avanzando avanzandoentre los inmensos jardinesbordaban la margen del río llegó al fin al pielas rocas sobrese eleva la ermitasan saturio tal vez desde esta altura podré orientarmeseguir mis pesquisas a travésese confuso laberinto exclamó trepandopeña en peña con la ayudasu daga\n\n"
+ "legó a la cima desde lase descubre la ciudad en lontananza ygran parte del duerose retuerce apies arrastrandocorriente impetuosa y oscuraentre las corvas márgeneslo encarcelan\n\n"
+ "manriquevez en lo altolas rocas tendió la vista a su alrededor pero al tenderla y fijarla al cabo enpunto no pudo contenerblasfemia\n\n"
+ "a luzla luna rielaba chispeando en la esteladejaba en possíbarcase dirigía a todo remo a la orilla opuesta\n\n"
+ "en aquella barca había creído distinguirforma blanca y esbeltamujer sin duda la mujerhabía visto en los templarios la mujersus sueños la realizaciónsus más locas esperanzas se descolgólas peñas con la agilidadun gamo arrojó al suelo la gorra cuya redonda y larga pluma podía embarazarlecorrer y desnudándose del ancho capotilloterciopelo partióuna exhalación haciapuente\n\n"
+ "pensaba atravesarlo y llegar a la ciudad antesla barca tocase en la otra orilla ocura cuando manrique llegó jadeante y cubiertosudor a la entrada ya loshabían atravesadoduerola partesan saturio entraban en soriaunalas puertas del muroen aquel tiempo llegaba hasta la margen del río en cuyas aguas se retratabanpardas almenasaunque desvanecida su esperanzaalcanzar a loshabían entradoel postigosan saturio noeso nuestro héroe perdió lasaber la casaen la ciudad podía albergarlos fija en su mente esta idea penetró en la población y dirigiéndose haciabarriosan juan comenzó a vagarsus calles a la ventura\n\n"
+ "as callessoria eran entonces y lo son todavía estrechas oscuras y tortuosassilencio profundo reinaba en ellas silenciosólo interrumpían oralejano ladridoun perro orarumoruna puerta al cerrarse orarelinchoun corcelpiafando hacía sonar la cadenale sujetaba al pesebre en las subterráneas caballerizas\n\n"
+ "manrique conoído atento a estos rumoresla nocheunas veces le parecían los pasosalguna personahabía doblado ya la última esquinaun callejón desierto otras voces confusasgenteshablaban aespaldas ya cada momento esperaba ver a su lado anduvo algunas horas corriendo al azarun sitio a otro\n\n"
+ "por último se detuvo al pieun caserónpiedra oscuro y antiquísimo y al detenerse brillaronojos conindescriptible expresiónalegría ende las altas ventanas ojivalesaquelpudiéramos llamar palacio se veíarayoluz templada y suavepasando a travésunas ligeras colgadurasseda colorrosa se reflejaba ennegruzco y grieteado paredónla casaenfrente\n\n"
+ "no cabe duda aquí vive mi desconocida murmurójoven en voz baja sin apartarpuntoojosla ventana gótica aquí vive ella entróel postigosan saturioel postigosan saturio se viene a este barrio en este barrio haycasa donde pasada la media noche aún hay gente en vela en vela quién sino ellavuelvesus nocturnas excursiones puede estarlo a estas horas no hay más ésta es su casa\n\n"
+ "en esta firme persuasión y revolviendo en su cabeza las más locas y fantásticas imaginaciones esperóalba frente a la ventana góticalaen toda la noche no faltó la luz ni él separó la vistamomento\n\n"
+ "cuando llegódía las macizas puertas del arcodaba entrada al caserón y sobre cuya clave se veían esculpidos los blasonessu dueño giraron pesadamente sobre los goznes conchirrido prolongado y agudoescudero reapareció endintel conmanojollaves en la mano restregándose los ojos y enseñando al bostezarcajadientes capacesdar envidia acocodrilo\n\n"
+ "verle manrique y lanzarse a la puerta todo fue obraun instante\n\n"
+ "quién habita en esta casa cómo se llama elladónde es a qué ha venido a soria tiene esposo responde responde animal Ésta fue la salutaciónsacudiéndolebrazo violentamente dirigió al pobre escuderocual despuésmirarlebuen espaciotiempo con ojos espantados y estúpidos le contestó con voz entrecortadala sorpresa\n\n"
+ "en esta casa vivemuy honrado señor d alonsovaldecuellos montero mayornuestro señorreyherido en la guerra contra moros se encuentra en esta ciudad reponiéndosesus fatigas\n\n"
+ "pero y su hija interrumpiójoven impaciente y su hija o su hermana o su esposa o losea\n\n"
+ "no tiene ninguna mujer consigo\n\n"
+ "no tiene ninguna pues quién duerme allí en aquel aposento donde toda la noche he visto arderluz\n\n"
+ "allí allí duerme mi señor d alonsocomo se halla enfermo mantiene encendida su lámpara hastaamanece\n\n"
+ "un rayo cayendoimproviso apies no le hubiera causado más asombroelle causaron estas palabrasyo la heencontrar la heencontrar y si la encuentro estoy casi seguroque heconocerla en qué eso es lono podré decir pero heconocerlaecosus pisadas osola palabra suyavuelva a oírextremosu trajesolo extremovuelva a ver me bastaránconseguirlo noche y día estoy mirando flotar delantemis ojos aquellos plieguesuna tela diáfana y blanquísima noche y día me están sonando aquí dentro dentrola cabezacrujidosu trajeconfuso rumorsus ininteligibles palabras qué dijo qué dijo ah si yo pudiera saber lodijo acaso pero aún sin saberlo la encontraré la encontraré me lo dacorazón y mi corazón no me engaña nunca verdad esya he recorrido inútilmente todas las callessoriahe pasado noches y noches al sereno hecho posteuna esquinahe gastado másveinte doblas en oro en hacer charlar a dueñas y escuderoshe dado agua bendita en san nicolás avieja arrebujada con tal arte en su mantoanascotese me figuródeidad y al salirla colegiatanochemaitines he seguidoun tonto la litera del arcediano creyendoel extremosus holapandas eradel trajemi desconocida pero no importa yo la heencontrar y la gloriaposeerla excederá seguramente al trabajobuscarla\n\n"
+ "cómo seránojos debenser azules azules y húmedosel cielola noche me gustan tanto los ojosese color son tan expresivos tan melancólicos tan sí no hay duda azules debenser azules son seguramente ycabellos negros muy negros y largosque floten me parecelos vi flotar aquella noche al parsu traje y eran negros no me engaño no eran negros\n\n"
+ "y qué bien sientan unos ojos azules muy rasgados y adormidos ycabellera suelta flotante y oscura amujer alta porque ella es alta alta y esbeltaesos ángeleslas portadasnuestras basílicas cuyos ovalados rostros envuelven enmisterioso crepúsculo las sombrassus doselesgranito\n\n"
+ "su voz su voz la he oído su voz es suaveel rumor del viento en las hojaslos álamos y su andar acompasado y majestuosolas cadenciasuna música\n\n"
+ "y esa mujeres hermosael más hermosomis sueñosadolescentepiensayo piensogustayo gustoodia loyo odioesespíritu humanomi espírituescomplementomi ser no se hasentir conmovida al encontrarme no me haamaryo la amaréla amo ya con todas las fuerzasmi vida con todas las facultadesmi alma\n\n"
+ "vamos vamos al sitio donde la vi la primera y única vezle he visto quién sabe si caprichosayo amigala soledad ymisteriotodas las almas soñadoras se complace en vagarentre las ruinas ensilenciola noche\n\n"
+ "dos meses habían transcurrido desdeel escuderod alonsovaldecuellos desengañó al iluso manrique dos meses durante los cuales en cada hora había formadocastillo enairela realidad desvanecía consoplo dos meses durante los cuales había buscado en vano a aquella mujer desconocida cuyo absurdo amor iba creciendo en su alma merced aaún más absurdas imaginaciones cuando despuésatrevesar absorto en estas ideaspuenteconduce a los templariosenamorado joven se perdió entre las intrincadas sendassus jardinesa noche estaba serena y hermosa la luna brillaba en toda su plenitud en lo más alto del cielo yviento suspiraba conrumor dulcísimo entre las hojaslos árboles\n\n"
+ "manrique llegó al claustro tendió la vistasu recinto y miró a travéslas macizas columnassus arcadas estaba desierto\n\n"
+ "salióél encaminópasos hacia la oscura alamedaconduce al duero y aún no había penetrado en ella cuandosus labios se escapógritojúbilo\n\n"
+ "fabía visto flotarinstante y desaparecerextremo del traje blanco del traje blancola mujersus sueñosla mujerya amabaun loco\n\n"
+ "corre corre en su busca llega al sitio enla ha visto desaparecer pero al llegar se detiene fija los espantados ojos ensuelo permanecerato inmóvilligero temblor nervioso agitamiembrostemblorva creciendova creciendo y ofrece los síntomasuna verdadera convulsión y prorrumpe al fincarcajadacarcajada sonora estridente horrible\n\n"
+ "aquella cosa blanca ligera flotante había vuelto a brillar anteojos pero había brillado apiesinstante no másun instante\n\n"
+ "erarayolunarayolunapenetraba a intervalosentre la verde bóvedalos árboles cuandoviento movíaramas\n\n"
+ "fabían pasado algunos años manrique sentado ensitial junto a la alta chimenea góticasu castillo inmóvil casi y conmirada vaga e inquietalaun idiota apenas prestaba atención ni a las cariciassu madre ni a los consuelossus servidores\n\n"
+ "tú eres joven tú eres hermoso le decía aquéllaqué te consumes en la soledadqué no buscasmujer a quien ames yamándote pueda hacerte feliz\n\n"
+ "el amoramor esrayoluna murmurabajoven\n\n"
+ "por qué no despertáisese letargo le decía unosus escuderos os vestíshierropies a cabeza mandáis desplegar al aire vuestro pendónricohombre y marchamos a la guerra en la guerra se encuentra la gloria\n\n"
+ "a gloria a gloria esrayoluna\n\n"
+ "queréisos digacantiga la últimaha compuesto mosén arnaldotrovador provenzal\n\n"
+ "no no exclamójoven incorporándose colérico en su sitial no quiero nada es decir sí quiero quierome dejéis solo cantigas mujeres glorias felicidad mentiras todo fantasmas vanosformamos en nuestra imaginación y vestimos a nuestro antojo y los amamos y corremos tras ellosquéquéencontrarrayoluna\n\n"
+ "manrique estaba locolo menos todomundo lo creía así a míel contrario se me figurabalohabía hecho era recuperarjuicio";
final String subst = "";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}