$re = '/^[:;,\-@0-9a-zA-Zâéè\'.\s]{6,20}$/';
$str = 'hellow';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);