using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?:^/|,[^,]+/)(?=')";
string input = @"/'Team1 = 6', while /'Team2 = 4', and /'Team3 = 2'";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}