re = /^(?:(?:(?:0?[1-9]|1\d|2[0-8])[\/](?:0?[1-9]|1[0-2])|(?:29|30)[\/](?:0?[13-9]|1[0-2])|31[\/](?:0?[13578]|1[02]))[\/](?:0{2,3}[1-9]|0{1,2}[1-9]\d|0?[1-9]\d{2}|[1-9]\d{3})|29[\/]0?2[\/](?:\d{1,2}(?:0[48]|[2468][048]|[13579][26])|(?:0?[48]|[13579][26]|[2468][048])00))$/m
str = '31/5/2000
31/05/2000
32/5/2000
30/6/2000
31/6/2000
28/2/2014
29/2/2014
28/02/2016
29/02/2016'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end