$re = '/^(?!0$)\d+/im';
$str = '12333
1
122
012
0
12
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);