$re = '/^[a-zA-Z\'-]+$/m';
$str = 'Manuel
Marth\'a
Manu-el
Manu9el';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);