re = /^(?:[ \t\v\f]*(?:(?:\r\n|\r|\n)(?:(?:[ \t\v\f]*(?:\r\n|\r|\n))+|$)|$))|$/m
str = 'This is a paragraph.'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end