re = /\[([^,\]]+),([^,\]]+)\]/
str = ' this is the range of values [a1,b1] and [b1,a1]
this is the range of values (a1,b1) and [b2,a2]'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end