$re = '/^(OK|DIS)\t([^\t]*\t){2}1\t{1}/';
$str = 'OK3.99DACA1';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);