import re
regex = re.compile(r"\"([^\"]+(\"[^\"]+\")?)\"?$", flags=re.MULTILINE | re.IGNORECASE)
test_str = ("ООО \"Ð ÐµÐ´Ð°ÐºÑ†Ð¸Ñ Ð³Ð°Ð·ÐµÑ‚Ñ‹ КраÑноÑÑ€Ñкий рабочий\"\n"
"ООО \"Ð ÐµÐ´Ð°ÐºÑ†Ð¸Ñ Ð³Ð°Ð·ÐµÑ‚Ñ‹ \"КраÑноÑÑ€Ñкий рабочий\"\n"
"ООО \"Ð ÐµÐ´Ð°ÐºÑ†Ð¸Ñ Ð³Ð°Ð·ÐµÑ‚Ñ‹ \"КраÑноÑÑ€Ñкий рабочий\"\"")
subst = "«$1»"
result = regex.sub(subst, test_str)
if result:
print(result)