const regex = /(\/\/.*|\/\*[\s\S]*?\*\/)/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(\\\/\\\/.*|\\\/\\*[\\s\\S]*?\\*\\\/)', 'gm')
const str = `// comments at the beginning of the file are removed
/*
Block comments are removed - easy peasy
*/
https://urls.are.preserved.for.you// and comments after them are removed
asdfasdf// the comment can bump right up to text
asdfasdf;// ...or a semicolon.
{
foo:// you will need a parser to remove this comment b/c it smells like a URL
"bar",// ...but not this one
boo: // ...or this one
"who"
}
while (list(\$key, \$value) = each(\$_GET))
/* some code;
while (list(\$key, \$value) = each(\$_GET))
some code;
*/
while (list(\$key, \$value) = each(\$_GET))
// while (list(\$key, \$value) = each(\$_GET))
//while (list(\$key, \$value) = each(\$_GET))`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}