$re = '/^\d*/m';
$str = '1test
2test
54testa3asdf
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);