re = /(\w*\.\w*)/m
str = 'seven hundred people found dead devastating seven.eight magnitude earthquake hits Nepal'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end