re = /(0[1-9]|1[0-9]|2[0-9]|3[01])\.(0[1-9]|1[012])\.(?:19|20)[0-9]{2}/m
str = '14.04.1989'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end