re = /\G\[([^][]*)]\h+([^][]+$)?/m
str = '[2021-03-10 00:13:32.901] [DefaultDispatcher-worker-2 @coroutine#3] [DEBUG] [4231c006d9083a302fce59d5f0957226] [42c5ac3c0acfc68d] [GreeterImpl] Hello John'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end