using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(^|[^а-яА-ЯёЁ])(МКУ|ИП)(?![а-яА-ЯёЁ])";
string input = @"""Саша""ИП""Саша""";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}