import re
regex = re.compile(r"^type=dog[\s\S]*?^name=(\w+)(?:(?:(?!^type=)[\s\S])*?^color=(\w+))?", flags=re.MULTILINE)
test_str = ("type=dog\n"
"sex=male\n"
"name=wolf\n"
"color=brown\n"
"type=dog\n"
"sex=male\n"
"name=bob\n"
"type=cat\n"
"sex=male\n"
"name=tom\n"
"color=black\n"
"type=dog\n"
"sex=female\n"
"name=simona\n"
"color=white")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")