$re = '/(?<Priority>[^\t\s]+)[\t\s]+(?<Date>[^\t\s]+)[\t\s]+(?<Thread>[^\t\s]+)[\t\s]+(?<Category>[^\t\s]+)[\t\s]+(?<Message>.+)/m';
$str = 'INFO 2019-08-21 11:42:41,448 [0x00000bec] [eiam.server.ipoz.sponsor] Sponsor::Sponsor: Poz initialized';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);