import re
regex = re.compile(r"[\xC0-\xD6\xD8-\xF6\xF8-\xFF\x{100}-\x{2AF}\x{388}-\x{3EF}]", flags=re.MULTILINE)
test_str = ("Different languages to test:\n\n"
"Napiszę tutaj trochę po polsku, żeby uzyskać znaki specjalne. To jest tylko do testowania. Szybki brązowy lis przeskoczył nad leniwym psem.\n\n"
"Unë thjesht do të shkruaj disa gjëra shqipe këtu për të marrë karaktere të veçanta. Kjo është vetëm për testim. Dhelpra e shpejtë kafe u hodh mbi qenin dembel.\n\n"
"Mən burada xüsusi personajlar əldə etmək üçün bir az azərbaycanca yazılar yazacam. Bu sadəcə sınaq üçündür. Sürətli qəhvəyi tülkü tənbəl itin üstündən atladı.")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")