using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^(?:(?:\(\d{3}\)\s|\d{3}-)\d{3}-\d{4})$";
string input = @"(123) 456-7890
123-456-7890
(123456-7890
(123-456-7890
";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}