package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)\d+\s*\w+\s*\d+`)
var str = `1920 x 1080 (Full HD)`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}