const regex = /^\d{5}\s[A-Z\s]*[A-Z]$/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^\\d{5}\\s[A-Z\\s]*[A-Z]$', 'gm')
const str = `12345 CAR
123 CAR IS
55555 CAR IS SUPER FAST
55555 CAR IS SUPER FAST `;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}