# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"(\.(fit|link)+?)(?:$|\/|\:)"
test_str = ("ill.com.au@hitme.fit\n"
"something@hitme.fit\n"
"something.fit@hitme.fit\n"
"something.link@hitme.fit\n"
"1axcjcbue5xsahq5evlru8vi84l8phe4kd5rmv-user=domain.com.au@5841205t.scamlottery.com\n"
"1axcjcbue5xsahq5evlru8vi84l8phe4kd5rmv-user=domain.com.link@5841205t.scamlottery.com\n"
"no.hit.link@account.fitbit.com\n"
"no.hit.fit@account.fit.com\n"
"something@fit.com\n\n"
"www.hitme.fitbit/url\n"
"www.hitme.fitbit:443/url\n"
"www.hitme.fitbit/url\n"
"ftp://hitme.good.com/unknown\n"
"ftp://hitme.fitbit/unknown\n"
"ftp://hitme.fitbit:23/url.link/\n"
"ftps://hitme.good.com/unknown\n"
"ftps://hitme.fitbit/unknown\n"
"ftps://hitme.fit:23/url.link/\n\n"
"hitme.fit\n"
"hitme.fit:443\n"
"hitme.fit/link\n"
"www.hitme.fit\n"
"www.hitme.fit:443\n"
"www.hitme.fit/link\n"
"https://hitme.fit\n"
"https://hitme.fit:443\n"
"https://hitme.fit/link\n"
"https://www.hitme.fit\n"
"https://www.hitme.fit:443\n"
"https://www.hitme.fit/link\n"
"https://hitme.link/transactional/link/6111b67123123fd001d7da8b2/\n\n"
"https://good.link.com/transactional/link.fit/6111b67123123fd001d7da8b2/\n"
"https://good.link.com/transactional/fit.link/6111b67123123fd001d7da8b2/\n\n"
"http://www.answers.com/article/1194427/8-habits-of-extraordinarily-likeable-people\n"
"http://www.apple.com\n"
"http://www.cnn.com.au/?link.fit/\n"
"http://downloads.news.com.au\n"
"http://ftp.android.co.nz\n"
"http://global.news.ca\n"
"http://www.apple.com\n\n"
"REV1 (:\\/\\/)?(\\w*\\.)*(link)(\\/.*)?$\n"
"REV2 (\\.(fit|link)+?)(?:$|\\/|:)")
matches = re.finditer(regex, test_str, re.MULTILINE)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.