package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`[a-zA-Z]+|\d+|[^\da-zA-Z]+`)
var str = `SW1A 1AA
SW1A
SW22 3`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}