$re = '/(\d+)(\w+)/m';
$str = '29pt 15rb 3as 1bl
14pt 3rb 2bl';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);