re = /Dell.*Streak|Dell.*Aero|Dell.*Venue|DELL.*Venue Pro|Dell Flash|Dell Smoke|Dell Mini 3iX|XCD28|XCD35|\b001DL\b|\b101DL\b|\bGS01\b/i
str = 'DellDellDellDellDellDellDellDell'
# Print the match result
str.match(re) do |match|
puts match.to_s
end