$re = '/(?<=\W)(?<! )\W+/';
$str = 'hello,.,.,.world.,.?,. ihg rglwglwhg wgwi lhg,./rmg.mhtr.h trhh ,/.,/,.*(&*&%^';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);