$re = '/\[(\d+)|[{\s](\w+):"?([^\s"]+)[",}]/m';
$str = 'm[1] = {text:"klass"};
m[2] = {number:1, text:"klass"};\';
m[21] = {number:1, text:"klass", liter:23};\';
m[22] = {number:1, text:"klass", liter:sometext};\';';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);