$re = '~(?:\*/.*?/\*|[^\w\s]+)(*SKIP)(*F)|\w+~m';
$str = 'Thank You!1!11 | )(^%& */person-first_name/* For Being Awesome */person-c235/* - Number 39658!? $450 | And Some moretextstuff */test/*
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);