re = /^(foo):\s*(["']?)(\w.*?)(?<=\w)\2$/m
str = 'foo: "bar"
foo: \'bar\'
foo: bar
foo: "bar\'
foo: \'bar"
foo: "bar
foo: bar"'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end