$re = '/(?m)^(\d[\d\r\n]*)^Подпись/m';
$str = 'Заключение:
1
2
3
Подпись';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);