#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)android\.com\/(intl\/[a-zA-Z]{2}\_[a-zA-Z]{2}\/)?$"
Local $sString = "android.com/intl/en_us/" & @CRLF & _
"android.com/intl/en_in/auto/" & @CRLF & _
"android.com/intl/en_us/auto/" & @CRLF & _
"android.com/intl/en_us/enterprise" & @CRLF & _
"android.com/enterprise/" & @CRLF & _
"android.com/work/84" & @CRLF & _
"android.com/enterprise/management/zero-touch/" & @CRLF & _
"android.com/security-center/" & @CRLF & _
"android.com//com.google.android.googlequicksearchbox" & @CRLF & _
"android.com/certified/partners/" & @CRLF & _
"android.com/" & @CRLF & _
"android.com/phones/" & @CRLF & _
"android.com/results/" & @CRLF & _
"android.com/versions/oreo-8-0/" & @CRLF & _
"android.com/filetransfer/" & @CRLF & _
"android.com/auto/" & @CRLF & _
"android.com/enterprise/" & @CRLF & _
"android.com/play-protect/" & @CRLF & _
"android.com/one/" & @CRLF & _
"android.com/intl/en_us/auto/" & @CRLF & _
"developer.android.com/work/index.html" & @CRLF & _
"android.com/everyone/" & @CRLF & _
"android.com/intl/en_in/auto/" & @CRLF & _
"android.com/intl/en_us/9" & @CRLF & _
"android.com/history/1" & @CRLF & _
"android.com/tv/" & @CRLF & _
"android.com/tablets/" & @CRLF & _
"android.com/enterprise/" & @CRLF & _
"developer.android.com/work/overview.html" & @CRLF & _
"android.com/enterprise/device-catalog/" & @CRLF & _
"android.com/intl/en_uk/auto/" & @CRLF & _
"android.com/switch/" & @CRLF & _
"android.com/enterprise/management/" & @CRLF & _
"android.com/gms/" & @CRLF & _
"android.com/intl/en_us/pay/" & @CRLF & _
"android.com/intl/en_us/one/" & @CRLF & _
"android.com/work/" & @CRLF & _
"android.com/intl/en_in/phones/" & @CRLF & _
"android.com/intl/en_uk/phones/" & @CRLF & _
"android.com/wear/" & @CRLF & _
"android.com/everyone/enabling-opportunity/" & @CRLF & _
"android.com/intl/en_us/phones/" & @CRLF & _
"android.com/play/" & @CRLF & _
"android.com/intl/en_au/phones/" & @CRLF & _
"android.com/intl/en_in/tv/" & @CRLF & _
"android.com/intl/en_us/tablets/" & @CRLF & _
"android.com/enterprise/" & @CRLF & _
"android.com/enterprise/management/" & @CRLF & _
"androidbusinesspartners.withgoogle.com/android/partners/search" & @CRLF & _
"android.com/gms/contact/" & @CRLF & _
"android.com/intl/en_in/wear/" & @CRLF & _
"android.com/intl/fr_fr/work/" & @CRLF & _
"android.com/pay/" & @CRLF & _
"android.com/security-center/" & @CRLF & _
"android.com/intl/en_ca/auto/" & @CRLF & _
"android.com/intl/en_in/wear/lg-watch-urbane-2nd-ed/" & @CRLF & _
"android.com/intl/en_uk/" & @CRLF & _
"android.com/intl/en_us/tv/" & @CRLF & _
"android.com/phones/tips/" & @CRLF & _
"android.com/enterprise/" & @CRLF & _
"android.com/enterprise/device-catalog/" & @CRLF & _
"android.com/enterprise/devices/" & @CRLF & _
"android.com/intl/ALL_en/work/" & @CRLF & _
"android.com/intl/en_in/" & @CRLF & _
"android.com/intl/en_in/results/" & @CRLF & _
"android.com/intl/en_in/switch/" & @CRLF & _
"android.com/intl/en_in/tv/sony-bravia/" & @CRLF & _
"android.com/intl/en_uk/pay/terms/" & @CRLF & _
"android.com/intl/en_uk/results/" & @CRLF & _
"android.com/intl/en_us/wear/" & @CRLF & _
"android.com/intl/it_it/work/" & @CRLF & _
"android.com/security-center/monthly-security-updates/" & @CRLF & _
"android.com/versions/nougat-7-0/" & @CRLF & _
"android.com/enterprise/devices/" & @CRLF & _
"android.com/enterprise/devices/" & @CRLF & _
"android.com/" & @CRLF & _
"android.com/enterprise/management/zero-touch/" & @CRLF & _
"androidbusinesspartners.withgoogle.com/android/partners" & @CRLF & _
"androidbusinesspartners.withgoogle.com/workpartners/accessdenied" & @CRLF & _
"android.com/intl/de_at/" & @CRLF & _
"android.com/intl/en_au/" & @CRLF & _
"android.com/intl/en_au/play-protect/" & @CRLF & _
"android.com/intl/en_au/work/" & @CRLF & _
"android.com/intl/en_ca/phones/" & @CRLF & _
"android.com/intl/en_in/phones/samsung-galaxy-s7-edge/" & @CRLF & _
"android.com/intl/en_uk/pay/" & @CRLF & _
"android.com/intl/en_uk/phones/pixel/" & @CRLF & _
"android.com/intl/en_us/pay/participating-banks/" & @CRLF & _
"android.com/intl/en_us/switch/" & @CRLF & _
"android.com/phones/samsung-galaxy-s7-edge/" & @CRLF & _
"android.com/filetransfer/" & @CRLF & _
"android.com/intl/en_us/" & @CRLF & _
"android.com/intl/de_de/security-center/" & @CRLF & _
"android.com/intl/en_au/auto/" & @CRLF & _
"android.com/intl/en_in/enterprie/" & @CRLF & _
"android.com/intl/en_uk/switch/" & @CRLF & _
"android.com/intl/en_uk/tv/sharp-aquos/" & @CRLF & _
"android.com/intl/en_us/everyone/" & @CRLF & _
"android.com/intl/es_es/security-center/" & @CRLF & _
"android.com/intl/it_it/tv/xiaomi-mi-box/" & @CRLF & _
"android.com/intl/ja_jp/work/" & @CRLF & _
"android.com/intl/pl_pl/security-center/" & @CRLF & _
"developer.android.com/work/guide.html" & @CRLF & _
"android.com/intl/en_uk/enterprise/devices/" & @CRLF & _
"android.com/intl/en_in/enterprise/device-collection/" & @CRLF & _
"android.com/auto/" & @CRLF & _
"android.com/certified/partners/" & @CRLF & _
"android.com/enterprise/security/" & @CRLF & _
"android.com/intl/en_in/enterprise/devices/" & @CRLF & _
"android.com/intl/en_us/auto/" & @CRLF & _
"android.com/phones/" & @CRLF & _
"android.com/results/" & @CRLF & _
"android.com/versions/oreo-8-0/" & @CRLF & _
"android.com//com.linkedin.android" & @CRLF & _
"android.com/auto/audi/" & @CRLF & _
"android.com/auto/ford/" & @CRLF & _
"android.com/everyone/research/" & @CRLF & _
"android.com/intl/en_au/auto/genesis/" & @CRLF & _
"android.com/intl/en_au/pay/" & @CRLF & _
"android.com/intl/en_au/results/" & @CRLF & _
"android.com/intl/en_au/security-center/" & @CRLF & _
"android.com/intl/en_au/tv/" & @CRLF & _
"android.com/intl/en_ca/" & @CRLF & _
"android.com/intl/en_ca/results/" & @CRLF & _
"android.com/intl/en_ca/security-center/" & @CRLF & _
"android.com/intl/en_ca/tv/nvidia-shield/" & @CRLF & _
"android.com/intl/en_ca/tv/sharp-aquos/" & @CRLF & _
"android.com/intl/en_hk/certified/partners/" & @CRLF & _
"android.com/intl/en_hk/pay/" & @CRLF & _
"android.com/intl/en_in/phones/htc-10/" & @CRLF & _
"android.com/intl/en_in/security-center/" & @CRLF & _
"android.com/intl/en_nz/phones/" & @CRLF & _
"android.com/intl/en_uk/auto/audi/" & @CRLF & _
"android.com/intl/en_uk/enterprise/" & @CRLF & _
"android.com/intl/en_uk/phones/samsung-galaxy-s7-edge/" & @CRLF & _
"android.com/intl/en_uk/tablets/" & @CRLF & _
"android.com/intl/en_uk/tv/sony-bravia/" & @CRLF & _
"android.com/intl/en_us/play/" & @CRLF & _
"android.com/intl/en_us/security-center/" & @CRLF & _
"android.com/intl/es-419_mx/security-center/" & @CRLF & _
"android.com/intl/es_es/tv/xiaomi-mi-box/" & @CRLF & _
"android.com/intl/pl_pl/work/" & @CRLF & _
"android.com/intl/ru_ru/security-center/" & @CRLF & _
"android.com/intl/ru_ru/work/" & @CRLF & _
"android.com/phones/moto-x/" & @CRLF & _
"android.com/security-center/publications/" & @CRLF & _
"android.com/security-center/whats-new/"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")